Скрипт для Mikrotik RouterOS. Выводит соответствие MAC - IP - Hostname из списка MAC адресов

Из списка MAC адресов формирует список IP и hostname, относящихся к этим MAC. Перед запуском скрипта сделать /tool ip-scan interface=etherN

https://github.com/devi1/RouterOS-scripts/blob/master/MAC%20to%20IP&Hostname

{:local arr {"70:85:C2:56:22:E2" ; "00:00:1B:00:AB:EF"};

foreach v in $arr do={

if ([len [/ip arp find where mac-address=$v]] >0) do={

:put [/ip arp get [find where mac-address=$v] address]};

if ([len [/ip dhcp-server lease find where active-mac-address=$v]] >0) do={

:put [/ip dhcp-server lease get [find where active-mac-address=$v] host-name]}

}

}