Конспекты по Excel: Функция ВПР

Для нахождения данных по строкам в таблице или диапазоне используется функция ВПР.

Потребуется следующая информация:

1. Значение, которое вам нужно найти, то есть искомое значение.

2. Диапазон, в котором находится искомое значение. Помните, что для правильной работы функции ВПР искомое значение всегда должно находиться в первом столбце диапазона.

3. Номер столбца в диапазоне, содержащий возвращаемое значение. Например, если в качестве диапазона вы указываете С2:Е11, следует считать С первым столбцом, D — вторым и т. д.

4. При желании вы можете указать слово ИСТИНА, если вам достаточно приблизительного совпадения, или слово ЛОЖЬ, если вам требуется точное совпадение возвращаемого значения. Если вы ничего не указываете, по умолчанию всегда подразумевается вариант ИСТИНА, то есть приблизительное совпадение.

Теперь объедините все перечисленное выше аргументы следующим образом:

=ВПР(искомое значение; диапазон с искомым значением; номер столбца в диапазоне с возвращаемым значением; при желании укажите ИСТИНА для поиска приблизительного или ЛОЖЬ для поиска точного совпадения).

Пример:

Допустим нам необходимо по ФИО сотрудника нати его з/п.

1. В строке "ФИО" указываем фамилию интересующего нас сотрудника

2. В строке "Зарплата" прописываем функцию ВПР:

=ВПР(C15;C2:E11;2;ЛОЖЬ)